Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Problem! Help!
Results 1 to 3 of 3

Thread: Problem! Help!

  1. #1
    latha
    Guest

    Default Problem! Help!

    Hi,

    I have a 2006 subaru impreza and love it. It has been great in my cold, snowy town in the UP. But over the last month or so, my battery has died three times. The first time was because my kid did not close his door properly, the second time, somehow that switch on top of the steering column was on, and tonight. I left the car running for the heat when I went to pick up my kid at the sitter's (late, cold night -10). When I came back, the engine was off, battery was really low and wouldn't start. I have left the car overnight where it was, got a ride home and need to go back tomorrow. Perhaps it would start with a jump, but i want to know what I did wrong! And how to fix it. Any help will be much appreciated.

    Thanks very much, Subaru folks

    Latha

  2. #2
    guydakine
    Guest

    Default

    Latha, Hi, well first get it checked out, could be I'd say one of 3 things, battery could have reached it's peak, voltage regulator, or the alternator. Have a mechanic check it with a tester and find out before throwing parts at it, could get expensive. First easy check you can do is see if there is water in your battery, refill using distilled about 3/4" from the top, you would need a jump and the alternator should charge it up with normal running.. Good luck.

  3. #3
    Noobinator
    Join Date
    Mar 2010
    Posts
    5
    Rep Power
    0

    Default

    Sounds like an alternator issue to me to. I just found this great video on how to replace one if you need it. Alternator video here

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •