Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
2000 subaru legacy gt wagon thumping noise in rear
Results 1 to 3 of 3

Thread: 2000 subaru legacy gt wagon thumping noise in rear

  1. #1
    Noobinator
    Join Date
    Nov 2011
    Location
    NEW MEXICO
    Posts
    1
    Rep Power
    0

    Angry 2000 subaru legacy gt wagon thumping noise in rear

    I recently purchased a 2000 Subaru GT wagon and there are lots of problems with it more then I bargained. I love the car but dam...I recently replaced the clutch and prior to that in the rear when I would let off the clutch too soon or sometimes normally it would make a THUMP in the rear. My mechanic will look into that also but it really needs to be fixed. It is scary driving it that way. I already replaced the sway bar in the front and a spindle assembly with ball joint and both drive shafts and a clutch. As well as both rack and pinion boots. It seems never ending and the car only has 152000 miles. It is an awsome car but I need to get it where I can trust it. Any light at the end of the tunnel? The car is kind of well taken car of but I think maybe they hit a bad pothole or curb or something. Then replaced the tires and didn't say anything lol. Before I take it to get it re aligned I need to know about that rear noise. Any common rear end thumping or CLONKING noise when letting off a clutch anyone? I would greatly appreciate it.

  2. #2
    TSF Top Poster
    Join Date
    Oct 2011
    Location
    San Francisco Area
    Posts
    105
    Rep Power
    0

    Default

    sounds like something is loose, and when torque is applied there is movement. maybe get the car on a lift and opperate the clutch normaly while someone is under looking and listening.

  3. #3
    TSF Top Poster
    Join Date
    Jan 2011
    Posts
    107
    Rep Power
    0

    Default

    I was just curious as to what sway bar link did you use in the process. Is there any particular brand I should look into? Thanks for your response.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •