Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
91 subaru legacy Help!
Results 1 to 5 of 5

Thread: 91 subaru legacy Help!

  1. #1
    Noobinator
    Join Date
    Oct 2011
    Posts
    3
    Rep Power
    0

    Default 91 subaru legacy Help!

    i have a 91 Subaru legacy i know you probably heard this about a million times. but i am having problems with the engine jerking when i get up between 20-30 speed. its alittle embarrassing trying to get up to speed. i know its not the transmission cause i took it in to a mechanic they said they couldn't find anything wrong if you have any suggestions please let me know. thanks.

  2. #2
    TSF Top Poster
    Join Date
    Oct 2011
    Location
    San Francisco Area
    Posts
    105
    Rep Power
    0

    Default

    Do you have a CEL[check engine light]?

    Does the jerking only happen between 20-30mph?

  3. #3
    Noobinator
    Join Date
    Oct 2011
    Posts
    3
    Rep Power
    0

    Default

    well the check engine light doesnt come on until it jerks alot.
    yes it only happens between 20-30 mph.

  4. #4
    TSF Top Poster
    Join Date
    Oct 2011
    Location
    San Francisco Area
    Posts
    105
    Rep Power
    0

    Default

    Do you know the condition of the spark plugs?

    If not, pull them out and inspect the gap for erosion, fouling, and overheating.

    Next, I would check the throttle possition sensor...

    ,,,then the A/F sensor[s].

  5. #5
    Noobinator
    Join Date
    Oct 2011
    Posts
    3
    Rep Power
    0

    Default

    i just replaced the spark plugs not too long ago. havent check the throttle positon senor or A/F sensor but i will check it and see if it cures the problem thank you soo much for your help!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •