Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
2009 WRX Idling Issue
Results 1 to 4 of 4

Thread: 2009 WRX Idling Issue

  1. #1
    Noobinator
    Join Date
    Apr 2011
    Posts
    1
    Rep Power
    0

    Post 2009 WRX Idling Issue

    My WRX has 17.5K and about a year ago I noticed that occassionally when making a stop the RPM's jump up to 2500 for 5-10 seconds when the engine is cold or hot. I took the car to the dealership since it is still under warranty and they claimed that I needed to use name brand premium gasoline. I have done this and this still does not correct the occassional high idle. A mechanic suggested that the computer may need an upgrade but the dealer said there were none available. The mechanic also suggested an occassional fuel system cleaner be added to a tank full of gas. Has anyone else experienced this issue?

  2. #2
    TSF Contributor
    Join Date
    Mar 2011
    Location
    Arkansas
    Posts
    73
    Rep Power
    0

    Default

    Yes. You do intact need to run premium, preferably without ethanol. Your car is drive by wire, as is mine, I took my throttle body completely off and cleaned it. You must take it completely off as this works the best.

  3. #3
    Noobinator
    Join Date
    Apr 2011
    Posts
    10
    Rep Power
    0

    Default

    Disconnect the battery for 10 minutes and re-connect, this could help the computer relearn proper idle.

  4. #4
    Noobinator
    Join Date
    Jun 2011
    Location
    ottawa canada
    Posts
    13
    Rep Power
    0

    Default

    check the gasket on your throttle body

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •