Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
96 legacy. radio,speedo and throttle quit all at once
Results 1 to 2 of 2

Thread: 96 legacy. radio,speedo and throttle quit all at once

  1. #1
    Noobinator
    Join Date
    Jul 2010
    Posts
    1
    Rep Power
    0

    Default 96 legacy. radio,speedo and throttle quit all at once

    Hey everyone. New here. I have a 96 suburu legacy brighton with the 4 cyclinder 5-speed AWD, 212,000 miles.

    My problem is, I was just driving to the bank drive-thru. All of a sudden the radio quit. Then I noticed the speedo quit, and the temp guage didnt seem to be reading correctly either, and then when I hit the gas, there was little to no power. It felt flooded, but kept running, but i couldnt get to more than about 5mph.

    Does this sound electrical? somethins as simple as a fuse?

    Any help would be greatly appreciated.

    Thanks!

  2. #2
    Admin Administrator's Avatar
    Join Date
    Feb 2008
    Location
    San Diego, CA
    Posts
    679
    Rep Power
    10

    Default

    I would check all the fuses first, then go from there!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •