Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
legacy problems
Results 1 to 3 of 3

Thread: legacy problems

  1. #1
    Noobinator
    Join Date
    Apr 2010
    Posts
    1
    Rep Power
    0

    Default legacy problems

    hi there am having problems with my 2002 legacy rs 3.0 when turning there is a whining noise abit like a whistle sound am wondering what it might be and if any one has any advice i thought it might be either power steering pump belt need tightening or power steering pump needing replacement any one have any suggestions

  2. #2
    Noobinator
    Join Date
    Jun 2010
    Posts
    2
    Rep Power
    0

    Default

    replace belt and adjust properly.

  3. #3
    Noobinator
    Join Date
    Nov 2010
    Posts
    7
    Rep Power
    0

    Default

    Check the power steering fluid. If it looks foamy, you are getting air in the fluid somehow. If you just did the belts or adjusted them you may have put a strain on the power steering hose connection where the belt guard bolts on to causing it to pull a bit and let air in. I'm assuming its the same design as my 2000 legacy. I tightened it up and changed the fluid (you have to once air gets in) and the noise was gone. Hope this helps

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •