Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
2001 legacy wagon ecm blows fuse
Results 1 to 4 of 4

Thread: 2001 legacy wagon ecm blows fuse

  1. #1
    rt100vt
    Guest

    Cool 2001 legacy wagon ecm blows fuse

    Hello to everyone,
    My wife's car died on the road the other day. 30 amp fuse for the ecm was blown so I replaced that and the car ran for a minute then died. Tried it again and it died after 5 seconds. Again and the fuse blew upon turning the key. If I take out the center connector to the ecm I can turn the key on and it does not blow. Now, the common response is that these units hardly ever go bad and that it is most likely that something else is shorted out but I am starting to wonder. What does "hardly ever" mean. The ecm only uses 5 volts can it blow a 30 amp 12 volt fuse?

    Con-fused

  2. #2
    t3ragtop
    Guest

    Default

    it's true that the cmos section of the ecu runs around 3.3vdc but there are supporting circuits like a wheatstone bridge that supports the hot wire anemometer in the maf that pull much more current and operate at higher voltages.

    the maf and some other sensitive devices have a dedicated shield/ ground that is separate from the vehicle's chassis ground or battery ground. sometimes little things like worn insulation can take just the chassis and dedicated ground together and completely trash an ecu depending on the voltage differential between the two.

    the ecu typically acts as a current "sink" for circuits like the fuel injectors. four injectors firing at one time (non-sequential) can pull currents in the 30 amp range and they have a pretty high inductive load. when the magnetic field collapses around an injector coil, it can throw some pretty wicked spikes into the ecu.

    i'd unplug the fuel injection relay and try to scan for codes. the diagnostics should indicate a dead code or no comms if the ecu is pooched.

  3. #3
    rt100vt
    Guest

    Default Thanks

    Nice explanation Noobinator. I just found a subaru service manual online and sent for it. Just didn't know where that circuit went but I will disconnect the injectors but now the fuse blows when you just turn the key to the on position.
    I found an ecu for $50 on ebay and that wasn't it...unless.
    I'll keep at it and thanks alot.

  4. #4
    rt100vt
    Guest

    Default

    er uh I mean t3ragtop.
    sorry it's late and I'm tired
    and it looks like I'm a noobinator too.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •