Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
'90 legacy running hot.
Results 1 to 8 of 8

Thread: '90 legacy running hot.

  1. #1
    snake
    Guest

    Default '90 legacy running hot.

    I've got a '90 legacy with 250K on the clock. It seems to cool OK idling but runs hot running down the road. Already had a thermostat swap, and one cooling fan isn't working. I know the fan should not have much to do with the driving /cooling part, but I still need to repair what we know is bad first. It is the passenger side fan, is that the condenser fan or the radiator fan as I cannot find any info on this. It isn't leaking oil in the water, or water in the oil, no known leaks but I'm starting to suspect a head gasket. Haven't tried the rad cap yet either, so maybe I should do that first? Also, where can you buy a fan? I found several on car-part.com (junkyard) but thats it so far...

    Thanks in advance...

  2. #2
    Suby Talker dieselrab's Avatar
    Join Date
    Aug 2009
    Location
    Indiana
    Posts
    34
    Rep Power
    0

    Default

    Well I don't think that it would be a radiator cap, normally it would still probably over heat at idle too, but that's not to say I would rule it out though either. Does your A/C work? Because if it works and you use it it should kick the A/C fan on then you would know which is which. You can unplug the connector on each fan and run jumper wires straight to your battery to see if they kick on. If you unplug ther connector and you have it facing you with the clip part pointing towards the sky the negative is the left terminal and the other two are positive(either one will work they are just two different speed settings just put it in on to see if the fan turns on). If it works then check fuses relays and wiring. I would think about changing the water pump, kind of sounds like it can't make enough flow in the systen to cool it while your driving it.

  3. #3
    TSF Top Poster Scorpion8's Avatar
    Join Date
    Dec 2008
    Location
    Juneau, AK
    Posts
    174
    Rep Power
    0

    Default

    Quote Originally Posted by dieselrab View Post
    I would think about changing the water pump, kind of sounds like it can't make enough flow in the systen to cool it while your driving it.
    Could be that. Is this a new or recent occurrence or has this always been happening with this car? When was the last time you had a radiator flush? Also, check to see if the coolant temperature switch is turning on the fan when it sould. You can try turning on the a/c which forces the sub-fan (2nd smaller fan) to come on and see if that cools it down. I don't recall if these vehicles also have a bottom plate piece below the radiator which forces airflow THRU the radiator instead of allowing it to go around, which would suggest only a problem while driving, not while idling. Some people on some cars remove that thinking it's extra junk and it's really there for a purpose.
    Retired USN
    94 Subaru Legacy L (RIP); 09 Subaru Forester; 98 Ford Contour GL+; 97 Dodge Ram 1500

  4. #4
    snake
    Guest

    Default

    Thanks for the advice so far... Not really sure about how long it has been doing it, it is a customers car- I do repair on the side so not a professional but lots of experience... The A/C doesn't work and I haven't looked into why it doesn't as he doesn't seem to care for some reason. I ran 12 V to the bad fan and it didn't turn, ohm'ed it and didn't show good, then plugged it into the other (driver's side) connector (they are the same believe it or not) and it didn't turn there either. Will that fan only turn when the A/C is on? Since the condensor is as long as the radiator, I assumed both would turn during hot idle and/or A/C. If I replace that fan on the passenger side and the A/C doesn't work, does that mean that side will never be needed anyway? The pass side had 12V going to the connector when I checked it so I assume it was supposed to be running... Also, the thermostat and waterpump were both swapped before I got the car with no improvement. Not sure if the rad has ever been flushed either, but normally a clogging rad will just run a bit hotter every year until it needs to be done. The customer stated that this thing runs right and all of a sudden it starts heating up like there is a restriction (lower hose collapsing maybe?)

  5. #5
    Suby Talker dieselrab's Avatar
    Join Date
    Aug 2009
    Location
    Indiana
    Posts
    34
    Rep Power
    0

    Default

    Well as far as I'm aware the smaller (sub fan as stated by scorpion8) on the passenger side will work when then A/C is on or when the engine is extreamly hot. If the fans dont opperate when connected directly to the battery they are junk. You can try to get the A/C to kick in by jumping the low side pressure sensor, located on the reciever drier on the passenger side by firewall. with a paper clip on what ever you have available. I know that there's four terminals not sure exactly jumping which two turns on the compressor I know one will turn on one fan one will turn on the other fan and one will jump the compressor (I know this for sure because I did this with my '93. A collapsing radiator hose could also cause this overheating problem.

  6. #6
    TSF Top Poster Scorpion8's Avatar
    Join Date
    Dec 2008
    Location
    Juneau, AK
    Posts
    174
    Rep Power
    0

    Default

    Quote Originally Posted by dieselrab View Post
    Well as far as I'm aware the smaller (sub fan as stated by scorpion8) on the passenger side will work when then A/C is on or when the engine is extreamly hot. If the fans dont opperate when connected directly to the battery they are junk. .....
    ^^^ What he said.
    Retired USN
    94 Subaru Legacy L (RIP); 09 Subaru Forester; 98 Ford Contour GL+; 97 Dodge Ram 1500

  7. #7
    TSF Top Poster
    Join Date
    Jan 2011
    Posts
    107
    Rep Power
    0

    Default

    I have learned a great deal about ac condenser concerns. Sorry to have revived this thread, but I just want to acknowledge the thread maker. Thanks for sharing the info.

  8. #8
    Noobinator
    Join Date
    Aug 2011
    Location
    Oregon
    Posts
    3
    Rep Power
    0

    Default

    Well in my 91 Legacy wagon i took my radiator out, and in front of it under neath my front gaurd and grill is the ac condernser. And for some reason which is probably good, my fans do not turn on unless my engine is hot.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •