Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Evap code frustration
Results 1 to 4 of 4

Thread: Evap code frustration

  1. #1
    Goline
    Guest

    Default Evap code frustration

    For the past 2 years my mechanic has been trying to repair my 99 Legacy OB Ltd SW so that the check engine light (evap code) will stay off. We started with the gas cap, no dice......after a smoke test result (at a different shop) he then replaced the fuel tank filler neck, vent tubes & hoses, clamps & #2 vent valve solenoid.....

    The light stayed off for about 500 miles. Another smoke test last week and it indicated the filler tube and valve.

    Any suggestions?

    thanks,
    f

  2. #2
    TSF Top Poster rutech's Avatar
    Join Date
    Apr 2009
    Posts
    137
    Rep Power
    0

    Default

    Wow, that would be very frustrating. Not sure what to say about that really. Usually a smoke test is pretty straight forward, only thing I can think of is the filler tube was not installed properly and maybe the valve was defective or damaged on installation. I have seen the vent tubes get plugged and cause problems but then the smoke test will not show anything, that and you already replaced them. The only thing I can think of off hand is to make sure it is your filler tube and not a crack in your fuel tank near the tube and make sure the valve is not damaged, is working proberly and the line going to the valve is good. Other than that I am not sure, sorry I could not be more help to you. Let me know what you find out.

  3. #3
    Goline
    Guest

    Default

    rutech...

    yup lots of frustration and money! Thanks for taking the time to reply. I've another appt with my repair guy this friday and here's hoping for some luck.

    f

  4. #4
    TSF Top Poster Scorpion8's Avatar
    Join Date
    Dec 2008
    Location
    Juneau, AK
    Posts
    174
    Rep Power
    0

    Default

    Quote Originally Posted by Goline View Post
    rutech...

    yup lots of frustration and money! Thanks for taking the time to reply. I've another appt with my repair guy this friday and here's hoping for some luck.

    f
    Have him also look at the air intake box, and review Service Bulletin 11-59-00. It's a longshot, but ....
    Retired USN
    94 Subaru Legacy L (RIP); 09 Subaru Forester; 98 Ford Contour GL+; 97 Dodge Ram 1500

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •