PDA

View Full Version : New Subaru Stinks for Months - Typical?



Sue Baroo
02-08-2009, 02:51 PM
I bought a new, 2007 Subaru over a year ago. I only have 15,000 miles on it now due to my short, 5-mile drives to/from work. When I bought it, it had a problem. After driving it until it was hot, it would stink like something was burning off from under the car. We would notice this when we stopped. When we took it to the dealer, they said that was normal and would go away after a few long drives. Well, a few long drives (up to 3 hours) later, it still stunk. This went on for months. The dealer finally admitted that there was something sprayed underneath (rust proofing?) that still had to burn off. It finally did, and it doesn't stink now.

But, I want to know if anybody else had this experience. Did you? If so, please post.

roverguy
02-20-2010, 07:39 PM
Have the same thing on my parents '07 Outback with 18k on the clock.

testical_blister
02-23-2010, 02:47 PM
Have the same thing on my parents '07 Outback with 18k on the clock.

Tell me about it. I have the same problem too








___________________________________

Electrical Supercharger Article (http://www.superchargertuning.com/)

Sue Baroo
02-23-2010, 07:10 PM
Thank you for posting your problems. It's nice to know I'm not alone in this.

Here's another one for you. My 2007 Outback makes a clicking/clacking/or grinding noise in the drive train when it is less than 15 degrees F out and I accelerate through a turn, starting from a stop. Anybody else with a 2007 having that problem? I've had it in multiple times. The dealer has replace LOTS of stuff, but not the transmission.