PDA

View Full Version : Engine cranks and sparks, but won't start.



MilesAway1980
03-18-2012, 10:41 AM
Hi All,
I'm not sure if this is the right forum but I'm not sure where else to post this.
(If anyone can direct me to a forum that deals with older Subarus, that'd be great).

I'm working on a 1987 Subaru GL with a 1.8 FI motor. It's my friend's car, so I don't have a lot of experience with it. She said she had been having issues with it not starting lately, although it would eventually start and then be fine for a few days.

Yesterday, she was leaving my house and while backing up the car quit and died and wouldn't start again.

The engine cranks but won't start. It doesn't even sound like it's trying to.
I started looking things over to see what it might be and it looked like the ignition was in desperate need of a tuneup. The battery cables were corroded, and the terminals were cracked and split. The spark plugs looked like they hadn't been replaced in a long time and looked like they'd been burned (they were white and ashy), and the distributor cap and rotor were very corroded.

So, I replaced the spark plugs, plug wires, battery cables, distributor cap, rotor, and the oxygen sensor.

The engine still wouldn't start.

I pulled one of the spark plugs out and grounded it to the frame and cranked it and it was getting spark.

The fuel pump and fuel filter were recently replaced, and while cranking the engine, I could smell gas, so I assume it was getting fuel. I don't know how to check on a fuel injected engine (I mostly work on carburetors).

I also tried the coil from my truck since I knew it was good and it didn't make any difference.


What could it be?
Thanks for any help. This is my friend and her fiance's only car, so they're pretty stuck without it.