PDA

View Full Version : HELP!!!!!!! No flashers or turns......



royer subaru
10-09-2011, 07:44 PM
my Dad has a 2000 forester and just lost his turn signals..... push the hazzard button and nothing also. I check all fuses and even put all new ones in just to try. Still nothing..... Help please

royer subaru
10-10-2011, 06:47 PM
Any one...... A little nervous with him driving the car like that. Was tryin to save him a bit of money and not have to send it to the dealership

2007fuji
10-12-2011, 04:50 PM
check the hazard switch, if it comes unplugged or inop, your situation will occur. The turn signals power comes through the hazard switch...let me know what you find.

royer subaru
10-14-2011, 09:02 PM
Just put a new switch in and didn't fix it. I can hear what seems to be a relay click under the dash.... Its a.black box..... Could it be that?

2007fuji
10-15-2011, 05:41 PM
when are you hearing this click under the dash? when you push the hazard button, or use the turn signal switch...or both?

do the marker lights work when the headlights are turned on?

royer subaru
10-16-2011, 11:38 AM
The click happens when i push the hazard button and when i use the signal lever. The marker lights come on when the car is started. All lights are good......

2007fuji
10-17-2011, 10:16 PM
Sounds like your were on the right track with the relay, since all the bulbs opperate.

Remove the relay that you hear clicking and replace it with one just like it[a relay of the same kind in your fuse panel that opperates something else...something you know that works].

brandonmillsap
01-20-2012, 02:13 AM
my Dad has a 2000 forester and just lost his turn signals..... push the hazzard button and nothing also. I check all fuses and even put all new ones in just to try. Still nothing..... Help please

Based on my experience, I think something is wrong with the turn signal switch (http://www.autopartswarehouse.com/turn_signal_switch~pop.html), maybe you would consider having that checked as well.

smiffy6four
01-20-2012, 08:50 PM
Sounds like the flasher relay is bad; it ISN'T the same as any other relay. It has to be an actual flasher relay.