PDA

View Full Version : Missfire Problem



asscore
09-23-2011, 05:42 PM
Hi Guys,

Hoping you can help me out. A few months ago I bought a 2001 Legacy sedan, 5 speed. It ran great unitl the other day, while driving home from a trip I noticed the car was grumbling in 5th gear between 55-60mph.

Turn on the car the next day, check engine light is on.

So I take the car into the mechanic. He reads the codes as cyl 2 and 4 misfire. He tells me he thinks the car just needs a good tune up. During his tune up he does new plugs and wires, fuel filter. Calls me later and says the car still has a misfire on one of the cylinders, probably the coil pack - should he go ahead and try replacing it?

I say sure, of course. I need my car running right.
He calls me back today, he tried the new coil pack, and its still misfiring. He tried some injector cleaner as well. He doesn't know what else to do. He recommends I take it to someone who specializes in Subaru, or try a forum and see if this is a common issue or something like that.

He suspects maybe clogged injector or broken valve spring.

I would also like to note that while driving the car home when the car got to around 35-4k on the tach the check engine light started flashing.

Any suggestions?

mwbean
11-12-2011, 12:53 PM
one thing I have encountered recently is that I changed a MAF
on another vehicle and found out later after the same codes came
up that the "new" part I got from NAPA was bad. After getting a
another one from another source it started running right. the lesson-
don't always assume beacuse the part is new it works correctly.

but I would suggest taking it to a more experienced subaru Mechanic
the guy you are dealing with is just a general mechanic. but even so,
he should double check his work. sounds like he is just guesing and throwing
parts at it. not good for you... and your bank account.

2007fuji
11-15-2011, 12:23 AM
It sounds like mwbean is right, your mechanic is guessing. being that cylinder 2 and 4 are next to eachother, Im guessing you have a head gasket issue. have the guy do a compression test.