PDA

View Full Version : New WRX Owner -- Need Troubleshooting advice PLEASE HELP



AndrewD17
07-12-2011, 03:33 PM
Okay so heres the deal, I recently bought my first Subaru. Its a 2002 WRX with 73k on it. I love the car aside from this major issue I cant seem to figure out. First off it has the check engine light is on and heres the codes that came up:

453 EVAP
1590 idle speed control
1090 emissions
1092 emissions
1507 idol speed
0170 bank one lean
1088 emissions

Now when you drive the car, it runs good until it decides to fall on its face. i dont know how to explain it other than its like hitting a brick wall. It also likes to die sometimes when sitting at a stop. It seems to be completely random as to when the car does this, and it seems to be getting worse. The car is also under boosted running at about 7 pounds and feels a little slugish due to this. I did just replace the MAF sensor and put a new air filter on it since i had the codes run. The car has a cold air intake and a knock off HK blow off valve. I also know the emissions have been removed from the car and it is otherwise stock. A friend of mine said the under boosting could be because of boost leaking out of the blow off valve, but I dont think that could explain it falling on its face. Could it be a throttle body going bad? Anyway just looing for some help as to what it probably is rather than spending a bunch of time and money jst replacing things that it coulld be.
Thanks

Monstersubie
07-14-2011, 04:55 AM
A boost leak will make it fall on it's face, I had one, the lean and evaporate codes are couple together, prolly a vacuum leak in evap, check your evap purge solenoid.

EVO8WRX
07-21-2011, 02:34 AM
AndrewD17

Accidently responded to your thread.

Sorry