PDA

View Full Version : Wiper Problem!!



greatpacha1
11-28-2009, 02:11 PM
2005 impreza. So my windshield wipers stop working in the rain and have no clue what the problem is. I took it into the dealer to try to resolve the issue and the dealer couldn't re-create the problem. So pretty much im stuck with a car thats a hazard, and after arguing with the dealer for trying to charge me for something they didnt help with at all, they banned me from the dealership. LOL. Anyhow, has anyone had this problem, and or any idea on how to fix it. Ive tried fuse and checked the motor, and both were fine. I think water gets into somewhere and causes a short, but i have no idea where. This is a huge problem!

ericams
12-04-2009, 12:40 AM
check all wires leading into the wiper motor for cuts or rubing,

i do know that subaru has had issues with water leaks into the engine bay before causing shorts but that was in early to mid 90's cars

also you may try getting some liquid tape and or silicone and put a little around the wires where they enter the wiper motor.

be careful but an old trick is to take a water hose shoot it up into the air onto your car and then open the hood to see where water leaks in from. this is kinda hard and wet but it might give you a start on where to look for problems

good luck

suzzeyv
02-09-2010, 05:15 AM
Remove wiper arm from shaft.with ignition on, run wiper then switch wiper to off.this will return wiper shaft to the stop position.reinstall wiper arm to shaft with it sitting so as not to be touching frame. try your wipers again.