PDA

View Full Version : need some help.......



flyers7732
11-28-2009, 09:30 AM
alright i have an 07 sti dom3r 750 injectors tgv deletes perrin cold air intake and front mount, car has run fine for the last 700 miles, problem as of yesterday, i started it up at work the idle was high normal for warm up, then is dropped to normal idle then dipped low almost stalling a/f was 18 then went back to 14.6 usual idle for my car did this a few times at work then again later when i was sitting at wawa, driving around at 3k the car is jerky, let off the gas a/f goes 10-18 which it has never done b4 it usually goes right to dead lean, its never done that its acting funny its hard to explain but it is then step on the gas again it hesitates then runs normal, im clueless??? everything seems to be good, no leaks so idk what else to do, any help would be appreciated

ericams
12-04-2009, 02:26 AM
Serious call Kieth Fields at AWDtuning.com he is one of the best tuners in USA
his phone number is 817.501.0335 this is lewisville, texas which is central time

tell him that eric with AMS recommended you

thanks

bimmer4life2009
02-17-2010, 09:33 PM
Serious call Kieth Fields at AWDtuning.com he is one of the best tuners in USA
his phone number is 817.501.0335 begin_of_the_skype_highlighting**************817.5 01.0335******end_of_the_skype_highlighting this is lewisville, texas which is central time

tell him that eric with AMS recommended you

thanks

Thank you so much, I'm gonna give him a call tomorrow