PDA

View Full Version : Legacy (EJ20) Alternator woes.



one_happy_hippy
07-28-2009, 04:29 AM
Right.

Engine 1994(i think) subaru legacy 2.0l naturally EJ20 block.

Vehicle 1973 Vw transporter (camper)

Drove fine did 30miles + in the week, gave it a good run on the sat then went out on a 20mile run. Stopped at a petrol station and it wouldnt start up again, not even turning the starter. Jumped it and it start straight away rev'd up fine and drove fine. For about 2miles. Then revs dropping off and finally dying.

Again jumps starts fine, and idles fine - however put hazards / light on and engine starts to struggle idle poorly.

Mechanic put multi meter on it - reads 11.73v across battery terminals and the same from alterator to neg strap.

I was figuring dead alternator. However this has recently been replaced as had diff getting battery to charge. Had the original bench tested today and its working fine.

So this makes me wonder if there is a fault in the wiring to the alternator / regulator from the ignition loop.

This is supported by the fact there are only 2 wires coming of the alternator terminal (excluding main bat+ cable)


The connector has 4 pins - as it has been some what jury rigged to get it working (by v. capable mech) i dont know which terminals are in use.


the connector is Thus:


S D
IG L


S - Sense battery voltage
L - Ground to ingition light
IG - Ignition switch signal turns regulator ON
D - c**k only knows

So with only 2 wires im guessing they must complete the circuit from IG to L. Now im wondering if this means that the alternator doesnt sense the dropping battery voltage and that the alternator is sending enough charge to the battery. Or if the alternator would just feed a constant charge to the battery regardless of its charge state and that it is the alternator that is dead.

Does the battery voltage senser cable run directly to the battery or does it go via the ECU?

Any ideas?

Ta.

Scorpion8
07-30-2009, 12:22 AM
the connector is Thus:


S D
IG L


S - Sense battery voltage
L - Ground to ingition light
IG - Ignition switch signal turns regulator ON
D - c**k only knows

So with only 2 wires im guessing they must complete the circuit from IG to L. Now im wondering if this means that the alternator doesnt sense the dropping battery voltage and that the alternator is sending enough charge to the battery. Or if the alternator would just feed a constant charge to the battery regardless of its charge state and that it is the alternator that is dead.

Does the battery voltage senser cable run directly to the battery or does it go via the ECU?

Any ideas?

Ta.

My ref shows 3 wires in use: WH which goes to the battery, WH/BK which serves the dash carging lamp thru the ignition relay, and YE which goes to the ignition circuit. I don't have a pin-out diagram for that connector.

jrlegacy23
08-04-2009, 03:46 AM
You want a minimum of 13.2 volts at the battery. Most alternators put out at least 14 volts.